Vidpool configuration error

I am working on setting up vid-pool

[1] my depoly command is below

sudo docker run --rm -t -v /home/chanp/vidfolder:/state -w /state videocoinnetwork/vidpool -c /state/config-deploy.json deploy

[2] my config-deploy.json file is below
“DataDir”: “/state/”,
“KeyFile”: “keyfile.json”,
“Password”: “",
“StreamManagerAddress”: “0xA412ba6e9f341aA438E0551102713e583d9F8e8e”,
“StakingManagerAddress”: “0xaDAE0F8b1cf953C79F8A397cC8D0A209EAF00944”,
“TokenAddress”: “0x2c9023bbc572ff8dc1228c7858a280046ea8c9e5”,
“WorkerChainURL”: “”,
“PaymentsChainURL”: “”,
“LogLevel”: “debug”,
“PaymentURLSpec”: “”,
“Auth”: {

[3] I got an error message is

Error: rpc error: code = Unauthenticated desc = Authentication failed

vidpool execution failed with rpc error: code = Unauthenticated desc = Authentication failed

I put config-deploy.json file and ether-keyfile.json is in the /home/chanp/vidfolder

[4] I also execute flat command and It works
It seems that different config.json file is needed

message is below

DEBU[0001] using block number 12229687, hash 0xf30e864ff8c3fc25b796010486ec865cd7fc39cc9005522cd758ac7af5f6638d for estimation
INFO[0001] estimated price 76650000000
INFO[0001] estimated gas price is 76650000000
DEBU[0001] using sequential erc20 engine
DEBU[0001] nothing to recover
DEBU[0002] processing payments for delegations inbetween blocks 12229575 and 12229680
DEBU[0002] get snapshot up to 12229575
DEBU[0002] update state between 1 and 12229575
DEBU[0003] seconds passed between 12229575 and 12229681 - 1409
INFO[0003] percent to be paid between 12229575 and 12229681 - 4467909690/1000000000000000
DEBU[0003] get changed block after 12229576
DEBU[0003] update state between 12229575 and 12229679
DEBU[0003] updating report for interval between 12229575 and 12229679
DEBU[0004] seconds passed between 12229575 and 12229680 - 1406
INFO[0004] percent to be paid between 12229575 and 12229680 - 4458396752/1000000000000000
INFO[0004] executing payments up to block 12229680
DEBU[0004] updated last processed block to 12229680
SUMMARY 12229575 - 12229681


What should i do to complete my vid-pool setup??

Please help me…

The configuration that your are is using is old and invalid. Use the configuration file from the following location.

thanks for your answer…

but when I executed deploy command with the configuration file you gave,
I got a different error message like this

Error: rpc error: code = Unavailable desc = connection error: desc = “transport: Error while dialing dial tcp: missing address”

Replace the EthereumChainURL in the configuration file with your infura PROJECT-ID. You can use the same infura PROJECT-ID that you use while running your worker.

I already did that…
but same error getting an missing address .

Paste your worker address here. I will check the issue by running vidpool on your worker in dry run mode.( No password or private key required)

Here is my worker address



I tried dry run and it seems to be OK. Try this command on your side and let me know if you see any issue.

docker run --rm -t -v $PWD:/state -w /state videocoinnetwork/vidpool:v0.2.13 flat -c configure.json --dry-run -a 0x752157106a572b779ce5a3e1bd32d096a5e687cf --start 12110414 --end 12233226 --csv payments.csv


  • Use vidpool:v0.2.13 for docker image, just to make sure you are using the latest version,
  • dry-run performs same operation of accessing Ethereum Mainnet and VideoCoin blockchain, but will not make any payments. It will show if there are connection issues.
  • You can get help on the options such as start and end blocks using “docker run --rm -t -v $PWD:/state -w /state videocoinnetwork/vidpool:v0.2.13 flat --help”
  • You have to supply a configure.json with keyfile and password set as place holders, but dry-run will check these fileds, but will use not these fields. It will use the worker address supplied with -a option.

I see that your worker does not have any delegated stake at present. I assume that you are trying to check whether vidpool works.

I tried the command you gave me and it worked fine.

You mean my worker get ready to take delegate staking already?
I thought I should succeed to execute deploy command and my worker should show up Cash Reward Staking list down below .

So I tried to solve deploy command error like address missing.
Am i wrong?

I’m really appreciate of your kindness and fast answer…

Once you enable delegated staking for your worker using ViedoCoin console, VideoCoin Staking App automatically allows delegated staking on this worker. You can use “vidpool flat” command to distribute incentives to delegators.

The above procedure is for redistributing VID incentives to delegators. There is an alternate scheme where mining rewards received by worker(in fiat) can be distributed using Publicmint blockchain. For this, you can use “vidpool payout” command. You may have to indicate the scheme that you are following in your worker’s information page.

vidpool deploy is an optional command to save the block number (corresponding to last payment that you made) on the VideoCoin blockchain. If the command is not used the block number is saved in the folder that you mapped to /state folder.
We will look at this issue and update you.

Thanks and I feel really sorry about too many questions

It’s seemed that I completly misunderstood the procedure of enabling vid-pool.

But I still don’t know How to enable vid-pool on my worker and my worker is on Cash Reword Staking List so that other people delegate their vid to my worker.

please let me know…


For enabling your worker to receive delegated stake, you have to enable the option “Allow Third Party Delegates” for your worker.
You can see this setting in your worker dashboard in VideoCoin console. Select “workers” in VideoCoin console, and then select the worker that you want to configure. You can see this option. Once you set this option, your worker will be displayed in Staking App.

I finally get to know how to set up vidpool on worker.
But I think I still have long way to go to run vidpool

thanks a lot, sir ^^