Unbonding shows 0

Hi, as just discussed with Jason my Worker shows 0 at Locked in Unbonding. Earlier it said that min VID is locked until March 29. Now there is nothing left? What should I do?

Br, Jelle

AFAIK there was a bug with the older version of worker hub and if you had setup your worker with the older version this would happen. Try probe or withdraw using CLI (command line program).

I believe this would be the command

$ staker stake withdraw complete -k -s

Your self stake will be available after unbonding period i.e. on March 29.
As @BluBlu indicated, the amount is not shown in worker-hub UI dues to an issue that version. You have to use staker tool as discussed in the following thread.
If you have any issue running the staker tool on March 28, please let us know,

Hi, thanks. I’m gonna test it asap. Jason asked me to post my wallet address:


Thanks a lot for helping me out @BluBlu much appreciated!

Thanks @Ram_Penke, I will wait until the 28 for executing the commands and get back to you if needed.

Hi, I tried running the commands today, but keep getting an error. Key file does not exist. Seems to be something wrong with the path or file name?

Error: key file does not exist
delegate withdraw complete [flags]

-h, --help help for complete

Global Flags:
-k, --key string utc key file json content
-l, --loglevel string (default “INFO”)
-s, --secret string password to decrypt key file

2021/03/28 09:16:42 key file does not exist

Maybe I should move my key file to the tmp location like mentioned below, but not sure how to do that on a Mac: Can't find my self staked VID


Run the staker tool from the folder that contains your wallet key file.
The option “-v $PWD:/tmp” maps your current folder to docker container “/tmp” folder.

A little more explanation: if have your wallet keyfile (for example “keyfile.json”) in the current folder where your are running the staker tool, the tool running in the docker container will access the file as “/tmp/keyfile.json”. You don’t need to create /tmp folder. The current folder is automatically mapped tp /tmp becaus of the option “-v $PWD:/tmp”

Hi @Ram_Penke, thanks. Sorry I still don’t get it. Also my key wallet file doesn’t have the json extension added. I added the file to my dropbox account. Isn’t there an easier way to get this done? For mass adaption these things should be much easier / user friendly in my opinion.


I agree and understand the difficulty in using staker cli tool. Workerhub is created to address this issue and make worker deployment easy.
As discussed above, you need to use staker tool due to a bug in the worker-hub withdraw functionality. The issue is fixed in the latest release.

Regarding json extension of the keyfile, the file does not need json extension. It can have any name.

You may have to wait for some more time for unbonding of the worker to complete. The unbonding request was issued at 2021-03-08T16:32:01Z. It will complete after 21 days i.e. at 2021-03-29T16:32:01Z).

If you still see issue running the staker cli command, let us know,


@Ram_Penke stil getting the message key file does not exist. I did manage to run the command in the dropbox folder like this, but still getting the message file does not exist. But it’s in there…

docker run --rm -it --env=“ETH_RPC_URL=” -v $PWD:/tmp videocoinnetwork/staker stake withdraw complete -k /tmp/VideoCoin Worker -s

I also tried moving the key file to a different folder, but the same result. key file does not exist…

Try this:
step 1: copy your keyfile to current folder where you are running the staker command, using the following cp command

cp “/Users/jjdv584/Dropbox/VideoCoin Worker” ./mykeyfile.json

Step 2: Run the "staker stake withdraw complete "command as follows substituting your password. :

docker run --rm -it --env=“ETH_RPC_URL=” -v $PWD:/tmp videocoinnetwork/staker stake withdraw complete -k /tmp/mykeyfile.json -s “mykeyfilepassword”

Note: If you use special characters in your password, you have to escape them with backslash as shown in the following medium article.

@Ram_Penke sorry, that doesn’t work as well. No file is copied or moved to the folder im running the docker from. Not using special characters.

It may be file protection issue copying file from your drop box folder.

See if you can get help from some one to perform the step1. I can help you with the next steps once file is available in the folder, from where you are running the docker staker tool

Oke thanks I will. It should result in a file being created called mykeyfile.json right?

Yes, step1 should create that file.

If you are sure the keyfile is named as “Videocoin Worker” and exists in the folder /Users/jjdv584/Dropbox then you can try the following:

docker run --rm -it --env=“ETH_RPC_URL=” -v /Users/jjdv584/Dropbox:/tmp videocoinnetwork/staker stake withdraw complete -k “/tmp/VideoCoin Worker” -s “mykeyfilepassword”

@Ram_Penke I worked it out. As it turns out there was something wrong with the spaces indeed. In the end I copied the file from Dropbox to documents and ran the code like this: cp $ ls “VideoCoin Worker” ./mykeyfile.json

Also at first I was using Apple notes to copy and paste the lines you mentioned. Turns out this messes up the character encoding for the double quotes. Command line doesn’t like this. After typing it manually it worked:)

First i used: cp $ ls “VideoCoin Worker” ./mykeyfile.json
FATA[0000] could not decrypt key with given password version=dev

After that I realised I should place the passprashe between “” as well and it worked. My VID is in my wallet again:)

Thanks a lot!

1 Like