Create a Configuration File (Help)

Hello, Noob here. I have downloaded docker and pulled the docker image. Can you please provide instructions on how to create a configuration file and where to save it?

Hello there!

Heres a sample vars.env file. Put it in the same folder as the docker image and run it. The three lines in the config file are

KEY is your ETH keyfile that has ERC20-VID in it.
SECRET is your keyfile password
CLIENT_ID is the id you get from the worker dashboard.

Here’s how you get it Windows Setup Guide for VideoCoin Worker

Finally, run the docker command like this
docker run --rm --env-file vars.env videocoinnetwork/worker:latest

Remember to set up worker stake first.

Thanks, ive create the Key File, I keep getting the following error “The system cannot find the file specified.” I have tried to search where my docker images might be located and I cannot find the folder to input “vars.env”

I’ve added the required 10k VID on the KeyFile

Before you run the command, just make sure there’s a vars.env in that folder.

For example, if you ran command line from

Then drop vars.env in C:\Users\BulletToothTony

and run the docker command

Thanks for the reply, I put the Key file in the file location you suggested I still get the following error “The system cannot find the file specified.”


  1. Can you please paste the command you’re running on your machine
  2. Can you check your file name and see if it was vars.env
  3. go into the folder C:\Users\BulletToothTony and type
    and make sure vars.env is in the list there

@BulletToothTony We will also try this on Windows and let you know how it goes.

@BulletToothTony We tried this on Windows, no issues. Once you run the “dir” command we describe above, can you post a screenshot?

Remember to blur out any personal information like your name etc in the screenshot

I think it’s important to differentiate an Ethereum key file (private keys) vs. the environment file (*.env) being used by the worker machine. The vast majority of the contents of the ‘env’ file are the ETH key file contents but they are not the same.

The environment file also contains the CLIENT_ID of the worker machine so that it can tell the Docker container who it is on the network, as assigned at the time of worker account creation.

What I believe is going on here is that VideoCoin is using an env file + docker container to perform all the worker management (announcement, signatures, proofs, etc.), therefore it needs to “prove” it has the requisite VID ERC20 token funds on the Ethereum network, which bridges to the VideoCoin network.

I don’t know if this helps anyone, but it’s how I view it.

This is a good Medium article on Ethereum key store files and what the contents mean:

1 Like

I’m having a similar problem. I created a Worker with the following identification:

Client ID: 7405b9b2-299b-4b0c-977d-f28d0e717868
Worker Name: BDC- Prototype - i9-9900K @ 3.6 GHz
Ethereum network Wallet Address: 0x5ca10ec3f005BaEE952Ff80fdFc8CA1C80912C9d
Quantity of VID ERC20 in Address: 0

Here’s my configuration:

  1. Running Windows 10
  2. Running Docker Desktop in Linux Mode
  3. Created configuration file “vars.env” and placed in the following Windows DIR:
    “C:\Users\Santiago\Documents\Company Network\Computation Design (R&D)\Video Transcoding”
  4. Ran windows command prompt CMD.EXE using administrator privileges and then changed directory (CD) to same DIR as 3 above.
  5. Ran the worker command as follows:

C:\Users\Santiago\Documents\Company Network\Computation Design (R&D)\Video Transcoding>docker run --rm --env-file vars.env videocoinnetwork/worker:latest

Received the following error message from the network:

time=“2020-06-10T00:19:44.109968685Z” level=info msg=“finished client unary call” error=“rpc error: code = Unauthenticated desc = Authentication failed” grpc.code=Unauthenticated grpc.method=GetConfig grpc.service=cloud.api.dispatcher.v1.DispatcherService grpc.time_ms=227.146 span.kind=client system=grpc version=v1.0.0-everest-9bb45a7
time=“2020-06-10T00:19:44.110012685Z” level=fatal msg=“rpc error: code = Unauthenticated desc = Authentication failed” version=v1.0.0-everest-9bb45a7

I know that I have 0 (zero) VID in the wallet, and that this is less than the minimum required 50,000 VID, but this is a test. I’m getting authentication errors, which shouldn’t have anything to do with quantity, or does it? Is there something you have to approve on your end?

Any help appreciated.



Hi I am getting a similar message error: code = Unauthenticated desc = Authentication failed
I did not have the 50k on the ethereum chain, is that the reason while is it failing? Is that required to authenticated the worker?

Yes, probably. I just posted a number of lessons learned that I think you should read before you setup. I wish I had it before I started.

Like I said in another note, you’re trying to delegate, you should self stake